npm package discovery and stats viewer.

Discover Tips

  • General search

    [free text search, go nuts!]

  • Package details

    pkg:[package-name]

  • User packages

    @[username]

Sponsor

Optimize Toolset

I’ve always been into building performant and accessible sites, but lately I’ve been taking it extremely seriously. So much so that I’ve been building a tool to help me optimize and monitor the sites that I build to make sure that I’m making an attempt to offer the best experience to those who visit them. If you’re into performant, accessible and SEO friendly sites, you might like it too! You can check it out at Optimize Toolset.

About

Hi, 👋, I’m Ryan Hefner  and I built this site for me, and you! The goal of this site was to provide an easy way for me to check the stats on my npm packages, both for prioritizing issues and updates, and to give me a little kick in the pants to keep up on stuff.

As I was building it, I realized that I was actually using the tool to build the tool, and figured I might as well put this out there and hopefully others will find it to be a fast and useful way to search and browse npm packages as I have.

If you’re interested in other things I’m working on, follow me on Twitter or check out the open source projects I’ve been publishing on GitHub.

I am also working on a Twitter bot for this site to tweet the most popular, newest, random packages from npm. Please follow that account now and it will start sending out packages soon–ish.

Open Software & Tools

This site wouldn’t be possible without the immense generosity and tireless efforts from the people who make contributions to the world and share their work via open source initiatives. Thank you 🙏

© 2024 – Pkg Stats / Ryan Hefner

smartthings-phevctl

v1.9.0

Published

smartthings remote ctrl

Downloads

143

Readme

Smartthings and SMS Remote control for Outlander PHEV

SMS and Smartthings application wrapper over phevctl

  • Node.js CI
  • docker
  • NPM
  • donate

smartthings.gif smartthings.gif Charger.pngdoorLock.png

Features:

comparison of installation types

| Installation Type | Execute action(heating/cooling/headlights and etc...) | Smartthings Hub required | Internet connection required | can send/receive SMS | huawei e3372h-320(CL4E3372HM) / MikroTik LtAP mini LTE kit | Raspberry Pi must be installed | Send Push Notifications | |-----------------------------------------------------------------------------|--------------------------------------------------------|----------------------|------------------------------|----------------------|----------------------------------------------|--------------------------------|-------------------------| | Cloud Installation (run smartthings-phevctl on the cloud) | Immediately | No | Yes | No | Yes | No | Yes | | Cloud Installation with rapberry Pi(Cloud is forwarded smartthings-phevctl) | Immediately | No | No | Yes | Yes | Yes | Yes | | Сontrol over SMS without smartthings | 1-2 minutes delay | No | No | Yes | Yes | Yes | No | | Local Network Installation(under NAT) | Immediately | Yes | Yes | No | Yes | No | Yes | | Run without cloud and without Smartthings Hub | 2-5 minutes delay | No | No | Yes | Yes | Yes | Yes |

Cloud Installation

Without cloud installation

Outlander PHEV Registration

  • First need to register your phone on the original application Android or Apple or (Modified application)[https://github.com/vzakharchenko/remote-ctrl-gsm]
  • start Smartthings-phevctl Server
  • open server and enter your phone mac.

Installation Steps

  1. Install Server using Docker or raspberry Pi zero or Manual Installation
  2. create Device Handler
  3. create smartapp
  4. Configure smartthings application on android or apple
  5. Get "Smartthings Application Id" and "Smartthings Application Secret"
  6. Configure Server
  7. Add Smartthings devices

Server Docker Installation

  • Install docker
sudo su
curl -sSL https://get.docker.com | bash
usermod -aG docker $USER
  • Supported Architectures: amd64,x86-64,arm64,ppc64le,arm/v7
docker -d run --name=smartthings-phevctl  -p 8080:8080 -p 8099:8099 -p 8098:8098 --restart=always vassio/smartthings-phevctl

or

echo "{}">/opt/remote-ctrl-gsm.json
docker -d run --name=smartthings-phevctl  -p 8080:8080 -p 8099:8099 -p 8098:8098 -v /opt/config/remote-ctrl-gsm.json:/opt/remote-ctrl-gsm.json --restart=always vassio/smartthings-phevctl

Raspberry Pi Zero installation

  1. Download Raspberry Pi OS Lite
  2. write the Raspberry Pi OS image to the SD card using balenaEtcher or analog
  3. write empty "ssh" and wpa_supplicant.conf files on sdcard (boot)
  4. install phevctl, node(>=12) and smartthings-phevctl
sudo su
apt-get upgrade -y && apt-get -y install build-essential cmake git python3-distutils
mkdir /opt/phevctl
cd /opt/phevctl && git clone https://github.com/papawattu/msg-core
cd /opt/phevctl &&  git clone https://github.com/vzakharchenko/phevcore.git
cd /opt/phevctl && git clone https://github.com/DaveGamble/cJSON.git
cd /opt/phevctl && git clone https://github.com/vzakharchenko/phevctl
cd /opt/phevctl/cJSON && mkdir build && cd build && cmake .. && make && make install
cd /opt/phevctl/msg-core && mkdir build && cd build && cmake .. && make && make install
cd /opt/phevctl/phevcore && mkdir build && cd build && cmake .. && make && make install
cd /opt/phevctl/phevctl && mkdir -p build && cd build && cmake .. && make
rm -f /usr/bin/phevctl
ln -sf /opt/phevctl/phevctl/build/phevctl /usr/bin/phevctl
curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.37.2/install.sh | bash
source ~/.bashrc
nvm install --lts
# You can go drink coffee)
npm i pm2 -g
env PATH=$PATH:/usr/bin pm2 startup systemd -u root --hp ${HOME}
pm2 startup -u root
npm i smartthings-phevctl -g
pm2 start `npm root -g`/smartthings-phevctl/smartthings-phevctl.js
pm2 save

Server Manual Installation

sudo su
apt-get upgrade -y && apt-get -y install build-essential cmake git
mkdir /opt/phevctl
cd /opt/phevctl && git clone https://github.com/papawattu/msg-core
cd /opt/phevctl &&  git clone https://github.com/vzakharchenko/phevcore.git
cd /opt/phevctl && git clone https://github.com/DaveGamble/cJSON.git
cd /opt/phevctl && git clone https://github.com/vzakharchenko/phevctl
cd /opt/phevctl/cJSON && mkdir build && cd build && cmake .. && make && make install
cd /opt/phevctl/msg-core && mkdir build && cd build && cmake .. && make && make install
cd /opt/phevctl/phevcore && mkdir build && cd build && cmake .. && make && make install
cd /opt/phevctl/phevctl && mkdir -p build && cd build && cmake .. && make
rm -f /usr/bin/phevctl
wget -qO- https://getpm2.com/install.sh | bash
env PATH=$PATH:/usr/bin pm2 startup systemd -u ${currentUser} --hp ${HOME}
npm i smartthings-phevctl -g
pm2 start `npm root -g`/smartthings-phevctl/smartthings-phevctl.js
pm2 save

Smartthings installation

Create Custom DHT

  1. open https://graph.api.smartthings.com/
  2. open your location/ or create a new one
  3. open "My Device Handler" and "create New Device Handler"
  4. select from code and add [Outlander PHEV Action.groovy](./dht/Outlander PHEV Action.groovy), [Outlander PHEV Battery.groovy](./dht/Outlander PHEV Battery.groovy), [Outlander PHEV Thermostat.groovy](./dht/Outlander PHEV Thermostat.groovy) and [Outlander PHEV Doors.groovy](./dht/Outlander PHEV Doors.groovy)
  5. click save

Create SmartApp

  1. open https://graph.api.smartthings.com/
  2. open your location
  3. create a new SmartApp
  4. select from code and add remote-ctrl-gsm.groovy
  5. open smartapp application and click "App Settings"
  6. enable "OAuth"
  7. Save and publish application

Configure Smartthings application

  1. open smartthings application in Phone Android or Apple
  2. select location
  3. add SmartApp
  4. add "remote-ctrl-gsm"
  5. set IP and port of server and click save

Get "Smartthings Application Id" and "Smartthings Application Secret"

  1. open https://graph.api.smartthings.com/
  2. select smartapps in your location
  3. select your smartapp
  4. get "Smartthings Application Id" and "Smartthings Application Secret" from the page

Configure Server

  1. open server http://<IP>:8080
  2. default login/password: admin/admin
  3. configure "Smartthings Application Id", "Smartthings Application Secret" and mac address
  4. click save

Add a new Smartthings device

  1. select devices->add Device
  2. Device will be appear om Smartthings App

Local Network Installation(under NAT)

  • install [Smartthings Hub)[https://www.samsung.com/us/smart-home/smartthings/hubs/] on location.
  • during installation smartapp select hub.

Run without cloud and without Smartthings Hub

Authentication

Local authentication (default)

default login/password: admin/admin

change password for user

add a new User

Keycloak authentication

restart Application

Keycloak authorization

restart Application

Thermostat operation state

Push Notification

EVSE Electric Vehicle (EV) Charging Stations

Scripts for energy star charging stations

  • Slow charging(slowCharge.sh)
curl --header "application/x-www-form-urlencoded"   --request POST   --data 'cur_set=7&charge_start=1&adaptive_mode_status=1&adaptive_mode_voltage=220&timer=0&timer_start=0'   http://192.168.4.1/ajax
  • Normal charging(fastCharge.sh)
curl --header "application/x-www-form-urlencoded"   --request POST   --data 'cur_set=16&charge_start=1&adaptive_mode_status=0&adaptive_mode_voltage=220&timer=0&timer_start=0'   http://192.168.4.1/ajax
  • Disable charging(disableCharge.sh)
curl --header "application/x-www-form-urlencoded"   --request POST   --data 'cur_set=7&charge_start=0&adaptive_mode_status=1&adaptive_mode_voltage=220&timer=0&timer_start=0'   http://192.168.4.1/ajax
  • Mikrotik Configuration
/interface wireless security-profiles
add authentication-types=wpa2-psk group-ciphers=tkip mode=dynamic-keys name=EVSE supplicant-identity=MikroTik unicast-ciphers=tkip wpa-pre-shared-key=<EVSE_PASSWORD> wpa2-pre-shared-key=<EVSE_PASSWORD>
/interface wireless
set [ find default-name=wlan1 ] disabled=no frequency=2447 mode=station-pseudobridge name=EVSE_CHARGER security-profile=EVSE ssid=<EVSE_SSID>

/interface bridge
add dhcp-snooping=yes fast-forward=no igmp-snooping=yes name=bridgeEVSE
/interface bridge port
add bridge=bridgeEVSE broadcast-flood=no edge=no-discover interface=EVSE_CHARGER multicast-router=disabled trusted=yes unknown-multicast-flood=no unknown-unicast-flood=no
/interface bridge settings
set allow-fast-path=no

/ip dhcp-client
add add-default-route=no disabled=no interface=bridgeCar use-peer-dns=no use-peer-ntp=no
add add-default-route=no disabled=no interface=bridgeEVSE use-peer-dns=no use-peer-ntp=no

add authorization for EVSE Charging

  • start proxy application
npm i pm2 -g
env PATH=$PATH:/usr/bin pm2 startup systemd -u root --hp ${HOME}
pm2 startup -u root
npm i smartthings-phevctl -g
pm2 start `npm root -g`/smartthings-phevctl/evse-proxy.js
pm2 save
  • configure evse-proxy
nano ~/.remote-ctrl-gsm/config.json
{
 "evseServer": {
  "/": "https://192.168.4.1",
  "style.css": "https://192.168.4.1/style.css",
  "es.js": "https://192.168.4.1/es.js",
  "ajax": "https://192.168.4.1/ajax"
 },
 "users": [
  {
   "id": "0",
   "username": "admin",
   "password": "admin"
  }
 ],
 "port": 8011,
 "role":"<KEYCLOAK_REALM>:<KEYCLOAK_CLIENT>"
}
  • Keycloak authorization example keycloak.json:
{
  "realm": "<REALM>",
  "auth-server-url": "https://<KEYCLOAK_URL>/auth/",
  "ssl-required": "external",
  "resource": "<CLIENT_ID>",
  "credentials": {
    "secret": "<CLIENT_SECRET>"
  },
  "confidential-port": 0
}

Keycloak security role:

{
 "evseServer": {
  ...
 }
 ],
 "role":"<KEYCLOAK_REALM>:<KEYCLOAK_CLIENT>"
}